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plug-in for Adobe® Photoshop®

Manual
Version: 2.2.0

QR Code® Generator plug-in for Adobe® Photoshop® – Create QR Codes inside your composition. 

QR Codes can be generated as:
• URL (Link, Facebook like, Twitter follow, googleplus profiles, Youtube channels)
• Contact information (vCard 3.0 and MeCard Format)
• Calendar events
• Paypal payment links
• Wifi networks
• Geo location
• SMS, Phone number, eMail
• Plain text

You can create QR Codes in custom sizes without any aliasing effects. 
You have 4 levels to choose the reconstruction rate(redundancy level) depending on your needs. It’s 
recommended to use “high quality” for Design & Art QR Codes.
The QR Codes are generated offline, no internet connection is required. 

Questions? Contact our customer support:
support@EVEnX.com or visit http://www.evenx.com
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I.  Overview

System requirements
• : Platform Windows® PC ( Windows Vista® x86/x64, Windows 7® x86/x64, 

                                                            Windows 8® x86/x64)
   and
  Adobe® Photoshop® CS/CS2/CS3/CS4/CS5/CS6/CC (32/64-bit) 
      or Adobe® Photoshop® Elements 4/5/6/7/8/9/10/11/12 (32/64-bit)

           OR
• : Platform Intel® Macintosh® (  OS X® 10.7 Lion and up)
   and
  Adobe® Photoshop® CS5/CS6/CC (64-bit) 
      or Adobe® Photoshop® Elements 12 (64-bit)

Supported modes
• Color modes: 8/16/32 bit/Channel RGB/CMYK/LAB/Multichannel/Grayscale Mode 
• Character encoding: UTF-8 

Installation and uninstall
To install the plugin execute the delivered file and follow the instructions. Please restart
your host application afterwards.
You can access the plugin via Adobe Photoshop®'s filter menu (Filters->EVEnX->QR Code 
Generator).

To uninstall the plugin: 
• (for Windows)

select „QR Code Generator Plugin for Adobe Photoshop“ in the list of installed programs and 
double-click it.  

• (for Mac® OS X)
Launch „Applications/EVEnX.com/QR Code Generator“ and execute the uninstall script.  

It is not neccessary to uninstall trial or older version prior update installation. The installer will detect 
former versions and remove them automatically.

Upgrade policy
Our policy is to let our customers participate in our innovations.
Purchasing a product includes a 1-Year-Upgrade-Support.
Every update will be automatically delivered to our customer base.

We will send you an upgrade link to the eMail address you've provided with your order. 

Trial version restrictions
There a no time limits while using the Trial version of this plugin. But within this
version the string „powered by EVEnX.com“ is added to every generated QR Code. This
enlarges the resulting code. Please buy full version to create QR codes without this string.
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Trademarks
QR Code is registered trademark of DENSO WAVE INCORPORATED. 

Adobe and Photoshop are either registered trademarks or trademarks of Adobe Systems 
Incorporated in the United States and/or other countries. 

Windows, Windows 2000, Windows XP, Windows Vista, Windows 7 and Windows 8 are either 
registered trademarks or trademarks of Microsoft Corporation in the United States and/or other 
countries. 

Intel is a trademark of Intel Corporation in the U.S. and/or other countries.

Apple, Mac, Macintosh, Mac OS and OS X are trademarks of Apple Inc, registered in the U.S. and 
other countries.

All other trademarks are the property of their respective owners.
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II. GUI Description
2.1 Main Dialog:
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 Interaction mode
      zooming
       panning
       moving QR Code

 Content type

 Data fields
 available values
 for selected
 content type

 Preview
 zoom
 controls

 Add variable (see description 2.3)
(focus on text field enables button)
 insert data from list (format #VAR#)
 x   EXIF tag
 c   counter with start value
 p   full path and filename
 n   filename without extension
 ne filename and extension
 e   extension of file
 d   directory path of file
 dp parent directory of file
 t    change date/time of file 
 tc  creation date/time of file
 ta  access date/time of file
 tn  now (current date/time)
 w   document width
 h   document height
 win   document width in inch
 hin   document height in inch
 wcm   document width in cm
 hcm   document height in cm
 dpi document dpi (pixel per inch)
 dr  document ratio

Data controls
       loading
        saving
        clear forms
        clear all forms

 New layer
 creates 
 QR Code on 
 separate layer 

 Settings for
 (see description 2.2)
       QR Code
       Color
       Position
       Output 

 Help
 Select „Get Help“
 to view  manual
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2.2 Dialog Control „Settings“

In this control you can change the properties of  your QR Code.
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 Module size
 in pixel units

Reconstruction rate 
(tolerated reading errors)
     L ..  7%
     M..15%
     Q..25%
     H..30%

 Border
 (default is 4)
 in module units

 Color settings
 adjust foreground and
 background code color

 Position 
 - relative/absolute 
 (important for scripting)
 - offset adjustment sliders

 Background blending 
 merges background with
 existing pixels in layer
    0%  transparent QR background
100% full overlay

 Coding content
 shows the data
 encoded in the QR
 Code
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2.3 Dialog „Add Variable...“

This Dialog allows you to insert variables retrieved from the file properties, or add time stamps. 
If you have selected a variable, that contains a time, you can set the time format.

If your file contains a supported EXIF header, a variable called „exif tag“ shows up in the list. In the 
dropdown list you can specify the type of EXIF data you want to insert.
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 List of variables
 select one to insert

  Insert button
 adds selected variable
 to content field

  Finished
 close dialog if you're
 done

 Available time and date
 formats
 Dropdown list is enabled, if time 
variable is selected to insert
 M           month {1..12}
 MM        month {01..12}
 MMM     month {jan..dec}
 MMMM  month {january..december}
 d   day {1..31}
 dd   day {01..31}
 ddd   day {mon..sun}
 dddd   day {monday..sunday}
 yy   year 2 digits 
 yyyy  year 4 digits
 hh   hour 2 digits
 mm  minute 2 digits
 ss   second 2 digits
 t    time marker {A P}
 tt   time marker {AM PM}
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III.  Best Practice Guides
These lessons give you detailed description how to to use the QR Code Generator Plugin. 

(A) Best Practice Guide for creating a QR Code

1. Select the target layer and execute the plugin (Filters->EVEnX->QR Code Generator).

2. Choose the Type of QR Code you want to generate. These types are available:

• URL (Link, Facebook like, Twitter follow, googleplus profiles, Youtube channels)
• Contact information (vCard 3.0 and MeCard Format)
• Calendar events
• Paypal payment links
• Wifi networks
• Geo location
• SMS, Phone number, eMail
• Plain text

3. Fill in data fields.(You can see in preview, how you QR Code changes and grows.)

4. Select you prefered Reconstruction rate. (This determines, how many of the code can be  
destroyed but still maintain readability.) 
It's recommended to use "high quality" for Design QR Codes. This results in a larger, but 
well manipulatable code.

5. Select the Size of your code. (This value can be set between 1 and max. The algorithms  
doesn't use any aliasing, so QR Code recognition will be the best possible.)

6. Set Foreground(code) and Background color. Also you can change the Background 
merging of the QR Code.

7. Move the QR code to the position you want. (You can use either the horizontal and vertical  
sliders or the mouse, interaction mode set to move.)

8. Select wheter you want the code created on the current layer or on a new layer.

9. Press OK and the code is generated.
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(B) Best Practice Guide for creating a custom QR Code 
Follow the instruction described in (A)Best Practice Guide. 
Ensure to have selected "high quality" as Reconstruction rate.

Hue and Saturation
Changing the colors is a very simple way of altering the boring QR Code look.
Select the color or area you want to change and go to menu Image -> Adjustment -> 
Hue/Saturation (CTRL + U).
Experiment to find a suitable (and still readable) QR Code design. 

Outer Glow
Before adding outer glow you have to put the code against a dark background.
Then add a layer style to this layer(by clicking the FX button at the bottom of the 
layers window or double clicking on the layer).
In the style options check Outer Glow. 
Now try finding a valuable result changing spread, size and blend mode.

Gradient Overlay
Adding some gradient is a very effective way of altering the boring QR Code look.
Copy the black colored squares of the QR Code into a new layer and add a layer style 
to this layer(by clicking the FX button at the bottom of the layers window or double  
clicking on the layer).In the style options check Gradient Overlay.
Customize this gradient and get a very unique look. Choose dark colors to ensure 
readability, alternative you can reduce the effect blending value (opacity). 

Inner Glow
Copy the black colored squares of the QR Code into a new layer and add a layer style 
to this layer(by clicking the FX button at the bottom of the layers window or double  
clicking on the layer).
In the style options check Inner Glow.
Customize colors/size/choke to get a unique look. Choose dark colors to ensure 
readability, alternative you can reduce the effect blending value (opacity).
Experiment with other layer effect styles to get quick but amazing design results. 

Accented Edges
This is a way to change the complete look of the QR Code. It’s very important to take 
care of the the readability of the resulting art QR Code.
Select the area you want to change and go to menu Filter -> Brush Strokes -> 
Accented Edges .
Experiment to find a suitable (and still readable) code design. 

Rounding Edges
Round edges smooths the technical and industrial-like look of QR Codes. Select the 
black colored squares and smooth this selection (Select -> Modify -> Smooth).
To fill the resulting selection add a new layer and choose Edit -> Fill -> Black.
Don’t forget to uncheck the visibility of the original code. 

Enhance with logo
This way of altering your QR Code recommends generating it with a high error 
correction level (Q or H). Then your QR Code can resist up to 30% destruction but 
remains readable. These 30% can be used to superimpose a logo or other graphic 
enhancement.
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(C) Best Practice Guide for creating a QR Code Calendar event for a  
different timezone 

Imagine you have to create a QR Code for a Wedding invitation. You are in the United States and the 
Wedding ceremony will be celebrated in Paris, Western Europe on May, 15th at 14:00 CET.
You are in timezone Eastern Standard Time (EST GMT-5) and the target timezone is European Central 
Time (ECT GMT+1).
 

1. Select the target layer and start the plugin (Filters->EVEnX->QR Code Generator).

2. Choose the Type of QR Code you want to generate. 
In this guide we will select Calender event.

3. As timezone you have to set the Target timezone of the 
Wedding ceremony. 
Select ECT GMT+1 in the Timezone dropdown and verify, if the 
Daylight saving flag is set to on, as daylight saving is in effect 
on May in Paris. In our example the saved value will be 12:00 
UTC
(Inside QR Codes all time values are converted and saved as  
Unified Time Code values (UTC)).

4. Fill in remaining data fields.(You can see in preview, how you QR 
Code changes and grows.)

5. Select you prefered Reconstruction rate.
(This determines, how many of the code can be destroyed but  
still maintain readability.) 
It's recommended to use "high quality" for Design QR Codes. 
This results in a larger, but well manipulatable code.

6. Select the Size of your code. (This value can be set between 1 and max. 
The algorithms doesn't use any aliasing, so QR Code recognition will be 
the best possible.)

7. Set Foreground(code) and Background color. Also you can change the Background 
merging of the QR Code.

8. Move the QR code to the Position you want. (You can use either the horizontal and vertical  
sliders or the mouse, interaction mode set to move.)

9. Select wheter you want the code created on the current layer or on a new layer.

10. Press OK and the code is generated.
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 Resulting 
 UTC time 
 is 12:00:00
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(D) Best Practice Guide for adding Facebook Fan Page link

1. Select the target layer and start the plugin (Filters->EVEnX->QR Code Generator).

2. Choose the Type of QR Code you want to generate. 
In this guide we will select URL ->Facebook like.  

3. Retrieve your Facebook FAN PAGE ID. To retrieve it, simple browse to the main site of your 
Facebook page and take a look at the address bar on your browser.

If you have set up a Custom Fan Page, the ID you need is everything behind the slash in 
your web address bar, i.e.
http://www.facebook.com/  EVEnXcom  

Otherwise, if you haven’t set up a Custom Fan page, your FAN PAGE ID contains a little bit 
more:
http://www.facebook.com/  pages/EVEnXcom/18904524  

This is the ID you have to use for setting up a QR Code. Use EVERYTHING behind the domain 
address.

4. Insert your retrieved(yellow) string to the field FAN PAGE ID.

5. Select you prefered Reconstruction rate. (This determines, how many of the code can be  
destroyed but still maintain readability.) 
It's recommended to use "high quality" for Design QR Codes. This results in a larger, but 
well manipulatable code.

6. Select the Size of your code. (This value can be set between 1 and max. The algorithms  
doesn't use any aliasing, so QR Code recognition will be the best possible.)

7. Set Foreground(code) and Background color. Also you can change the Background 
merging of the QR Code.

8. Move the QR code to the position you want. (You can use either the horizontal and vertical  
sliders or the mouse, interaction mode set to move.)

9. Select wheter you want the code created on the current layer or on a new layer.

10. Press OK and the code is generated.
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(E) Best Practice Guide for scripting: insert QR Code that contains  
current file name

This Guide shows how to use Adobe® Action Script in multiple images to add QR Codes containing 
the filenames. 

1. Start recording an action, select the target layer and start the plugin (Filters->EVEnX-
>QR Code Generator).

2. Choose the Type of QR Code you want to generate. 

3. For adding the filename, select the Content field and fill in the variable formatted like: 
#ne#. You can also push the button [Add variable..] and select variable from the list.

4. Select you prefered Reconstruction rate. (This determines, how many of the code can be  
destroyed but still maintain readability.) 

5. Select the Size of your code. (This value can be set between 1 and max. The algorithms  
doesn't use any aliasing, so QR Code recognition will be the best possible.)

6. Set Foreground(code) and Background color. Also you can change the Background 
merging of the QR Code.

7. Set Position switch to Relative. This allows you size independent positioning into the 
lower right corner. (This is important for scripting images of different size and ratio.)

8. Move the QR code to the lower right position. (You can use either the horizontal and  
vertical position sliders or the mouse with interaction mode set to move.)

9. Press OK and the code is generated. Stop recording action. Now you can use this Action 
Script on multiple images, every time the filename will be inserted.
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 Variable symbol
 type it 
 or choose from list

Add variable
 insert data from list (format #VAR#)
 x   EXIF tag
 c   counter with start value
 p   full path and filename
 n   filename without extension
 ne filename and extension
 e   extension of file
 d   directory path of file
 dp parent directory of file
 t    change date/time of file 
 tc  creation date/time of file
 ta  access date/time of file
 tn  now (current date/time)
 w   document width
 h   document height
 win   document width in inch
 hin   document height in inch
 wcm   document width in cm
 hcm   document height in cm
 dpi document dpi (pixel per inch)
 dr  document ratio

 Filename will be
 added to the QR Code


	I.  Overview
	System requirements
	Supported modes
	Installation and uninstall
	Upgrade policy
	Trial version restrictions
	Trademarks

	II. GUI Description
	III.  Best Practice Guides
	(A) Best Practice Guide for creating a QR Code
	(B) Best Practice Guide for creating a custom QR Code 
	(C) Best Practice Guide for creating a QR Code Calendar event for a different timezone 
	(D) Best Practice Guide for adding Facebook Fan Page link
	(E) Best Practice Guide for scripting: insert QR Code that contains current file name


